文章目录

电脑上需要使用多个node.js版本,所以安装了nodist,nodit可以安装运行多个node.js版本。但是发现npm install xxx -g 全局安装的应用在运行的时候找不到
比如我安装了bower npm install bower -g
然后执行 bower install xxx会报错说找不到bower组件。
最后发现全局的组件安装到当前版本nodejs目录下了,实际上应该安装在nodist的bin/node_modules目录下。

在环境变量配置正确的情况下 执行nodist selfupdate即可,执行玩后再试试npm install -g 就发现完全正常了

此文是本站原创,转载请标注作者和链接出处!